# CVE-2022-43996: csaf-poc/csaf_distribution Cross-site Scripting vulnerability

> Attackers can execute arbitrary JavaScript in victim browsers by uploading crafted CSAF documents served as HTML.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Dec 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-xxfx-w2rw-gh63, GO-2022-1164

## What is CVE-2022-43996?

CVE-2022-43996 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The csaf_provider package before 0.8.2 allows XSS via a crafted CSAF document uploaded as text/html. The endpoint upload allows valid CSAF advisories (JSON format) to be uploaded with Content-Type text/html and filenames ending in .html. When subsequently accessed via web browser, these advisories are served and interpreted as HTML pages. Such uploaded advisories can contain JavaScript code that will execute within the browser context of users inspecting the advisory.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-43996?

3 open source packages ship an affected version, including github.com/csaf-poc/csaf_distribution. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/csaf-poc/csaf_distribution` | Go | All versions | 0.8.2 |
| `github.com/csaf-poc/csaf_distribution` | Go | All versions | 0.8.2 |
| `github.com/csaf-poc/csaf_distribution` | Go | All versions | 0.8.2 |

Products: Csaf Provider Project Csaf Provider.

## How do I fix CVE-2022-43996?

Upgrade github.com/csaf-poc/csaf_distribution to 0.8.2 or later.

## Is CVE-2022-43996 being exploited?

There is no known exploitation of CVE-2022-43996 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-43996 and fix it if it is affected.

What it is: CVE-2022-43996 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-43996 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/csaf-poc/csaf_distribution (Go): affected all versions; fixed in 0.8.2
- github.com/csaf-poc/csaf_distribution (Go): affected all versions; fixed in 0.8.2
- github.com/csaf-poc/csaf_distribution (Go): affected all versions; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-43996/ (Markdown: https://insights.sbomify.com/CVE-2022-43996/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-43996
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-43996
- OSV: https://osv.dev/vulnerability/CVE-2022-43996

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-43996/
Summaries are generated and may contain mistakes; the official description above is the record.
