# CVE-2022-44030: Missing authorization in n/a

> Attackers can download file attachments from any issue or wiki page due to insufficient permission checks, potentially exposing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-redmine-2022-44030, DEBIAN-CVE-2022-44030, GHSA-hq3g-q9w3-58pc, UBUNTU-CVE-2022-44030

## What is CVE-2022-44030?

CVE-2022-44030 is a high-severity missing authorization vulnerability in Redmine Redmine, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Redmine 5.x before 5.0.4 allows downloading of file attachments of any Issue or any Wiki page due to insufficient permission checks. Depending on the configuration, this may require login as a registered user.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2022-44030?

1 open source package ship an affected version, including redmine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redmine` | Bitnami | From 5.0.0 | 5.0.4 |

Products: Redmine Redmine.

## How do I fix CVE-2022-44030?

Upgrade redmine to 5.0.4 or later.

## Is CVE-2022-44030 being exploited?

There is no known exploitation of CVE-2022-44030 in the wild and no public exploit code.

## Other vulnerabilities in Redmine Redmine

- [CVE-2021-37156](https://insights.sbomify.com/CVE-2021-37156/): Security feature bypass in n/a (high 7.5)
- [CVE-2011-4929](https://insights.sbomify.com/CVE-2011-4929/): Command injection in n/a (high 7.5)
- [CVE-2009-4079](https://insights.sbomify.com/CVE-2009-4079/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2023-47258](https://insights.sbomify.com/CVE-2023-47258/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-47259](https://insights.sbomify.com/CVE-2023-47259/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-44030 and fix it if it is affected.

What it is: CVE-2022-44030 is a high-severity missing authorization vulnerability in Redmine Redmine, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-44030 in the wild and no public exploit code.

Affected packages and fixed versions:
- redmine (Bitnami): affected from 5.0.0; fixed in 5.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-44030/ (Markdown: https://insights.sbomify.com/CVE-2022-44030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-44030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-44030
- OSV: https://osv.dev/vulnerability/CVE-2022-44030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-44030/
Summaries are generated and may contain mistakes; the official description above is the record.
