CVE-2022-44031 Cross-site scripting in n/a
Persistent XSS in Redmine's Textile formatter allows attackers to inject malicious scripts via blockquote syntax, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-44031?
CVE-2022-44031 is a medium-severity cross-site scripting vulnerability in Redmine Redmine, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Redmine before 4.2.9 and 5.0.x before 5.0.4 allows persistent XSS in its Textile formatter due to improper sanitization of the blockquote syntax in Textile-formatted fields.
Weakness: CWE-79
Which versions are affected by CVE-2022-44031?
1 open source package ship an affected version, including redmine. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
redmine Bitnami | All versions | 4.2.9, 5.0.4 |
Products include Redmine Redmine.
How do I fix CVE-2022-44031?
Upgrade redmine to a fixed version for your release line: 4.2.9 or 5.0.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-44031 being exploited?
There is no known exploitation of CVE-2022-44031 in the wild and no public exploit code.
Other vulnerabilities in Redmine Redmine
Sources
Also known as BIT-redmine-2022-44031, DEBIAN-CVE-2022-44031, GHSA-8474-8wmh-7hj8, UBUNTU-CVE-2022-44031.