{"answers":{"affected":"4 open source packages ship an affected version, including topthink/framework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-44289 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-44289 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-44289 is a high-severity vulnerability in n/a, published on 6 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-44289 and fix it if it is affected.\n\nWhat it is: CVE-2022-44289 is a high-severity vulnerability in n/a, published on 6 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-44289 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- topthink/framework (Packagist): affected all versions up to 5.0.24; no fix listed\n- topthink/framework (Packagist): affected all versions up to 5.0.24; no fix listed\n- topthink/framework (Packagist): affected from 5.1 up to 5.1.41; no fix listed\n- topthink/framework (Packagist): affected from 5.1 up to 5.1.41; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-44289/ (Markdown: https://insights.sbomify.com/CVE-2022-44289/index.md)","id":"CVE-2022-44289","markdown":"https://insights.sbomify.com/CVE-2022-44289/index.md","name":"CVE-2022-44289","record":{"aliases":["GHSA-59fh-rjq3-xq7j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ThinkPHP framework","requires_auth":"low_privilege","summary":"Attackers can upload malicious files to execute arbitrary code on servers using the ThinkPHP framework.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"thinkphp","vendor":"thinkphp"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Thinkphp 5.1.41 and 5.0.24 has a code logic error which causes file upload getshell.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Thinkphp has a code logic error","id":"CVE-2022-44289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"SQL injection in n/a","id":"CVE-2022-44290"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["5.0.24"],"package":"topthink/framework","purl":null,"source":"GHSA-59fh-rjq3-xq7j"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["5.0.24"],"package":"topthink/framework","purl":"pkg:composer/topthink/framework","source":"GHSA-59fh-rjq3-xq7j"},{"ecosystem":"Packagist","fixed":[],"introduced":["5.1"],"last_affected":["5.1.41"],"package":"topthink/framework","purl":null,"source":"GHSA-59fh-rjq3-xq7j"},{"ecosystem":"Packagist","fixed":[],"introduced":["5.1"],"last_affected":["5.1.41"],"package":"topthink/framework","purl":"pkg:composer/topthink/framework","source":"GHSA-59fh-rjq3-xq7j"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2022-44284"},"products":["n/a"],"published":"2022-12-06","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2025-63888","kev_date_added":null,"published":"2025-11-20"},{"cvss_score":9.8,"headline":"ThinkPHP Path Traversal Vulnerability","id":"CVE-2025-50706","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2025-50707","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":9.8,"headline":"ThinkPHP deserialization vulnerability","id":"CVE-2024-48112","kev_date_added":null,"published":"2024-10-30"},{"cvss_score":9.8,"headline":"ThinkPHP deserialization vulnerability","id":"CVE-2024-44902","kev_date_added":null,"published":"2024-09-09"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in thinkphp","id":"CVE-2022-45982","kev_date_added":null,"published":"2023-02-08"},{"cvss_score":9.8,"headline":"ThinkPHP Framework vulnerable to remote code execution","id":"CVE-2022-47945","kev_date_added":null,"published":"2022-12-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["n/a"]},"summary":"Attackers can upload malicious files to execute arbitrary code on servers using the ThinkPHP framework.","url":"https://insights.sbomify.com/CVE-2022-44289/"}