CVE-2022-44303 Resque Scheduler Reflected XSS In Delayed Jobs View

Medium 6.1 Published Updated

Remote attackers can inject JavaScript into Resque Scheduler parameters, enabling client-side code execution in the web interface.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-44303?

CVE-2022-44303 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Resque Scheduler version 1.27.4 is vulnerable to Cross-site scripting (XSS). A remote attacker could inject javascript code to the "{schedule_job}" or "args" parameter in /resque/delayed/jobs/{schedule_job}?args={args_id} to execute javascript at client side.

Weakness: CWE-79

Which versions are affected by CVE-2022-44303?

2 open source packages ship an affected version, including resque-scheduler. It affects 1 product.

PackageAffectedFixed in
resque-scheduler RubyGemsFrom 1.27.44.10.2
resque-scheduler RubyGemsFrom 1.27.44.10.2

Products include Resque-Scheduler Project Resque-Scheduler.

How do I fix CVE-2022-44303?

Upgrade resque-scheduler to 4.10.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-44303 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44303 exists.

Sources

Also known as GHSA-9hmq-fm33-x4xx.

Is CVE-2022-44303 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free