# CVE-2022-44310: ecdh vulnerable to Exposure of Resource to Wrong Sphere

> An attacker can obtain the derived shared secret by sending an invalid public key point in the Development IL ecdh library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2023
- **Updated:** 12 Mar 2025
- **Also known as:** GHSA-p2hp-3wv3-4w74

## What is CVE-2022-44310?

CVE-2022-44310 is a high-severity vulnerability in n/a, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Development IL ecdh before 0.2.0, an attacker can send an invalid point (not on the curve) as the public key, and obtain the derived shared secret.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2022-44310?

2 open source packages ship an affected version, including ecdh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ecdh` | npm | All versions | 0.2.0 |
| `ecdh` | npm | All versions | 0.2.0 |

Products: Ecdh Project Ecdh.

## How do I fix CVE-2022-44310?

Upgrade ecdh to 0.2.0 or later.

## Is CVE-2022-44310 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44310 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-44310 and fix it if it is affected.

What it is: CVE-2022-44310 is a high-severity vulnerability in n/a, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44310 exists.

Affected packages and fixed versions:
- ecdh (npm): affected all versions; fixed in 0.2.0
- ecdh (npm): affected all versions; fixed in 0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-44310/ (Markdown: https://insights.sbomify.com/CVE-2022-44310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-44310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-44310
- OSV: https://osv.dev/vulnerability/CVE-2022-44310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-44310/
Summaries are generated and may contain mistakes; the official description above is the record.
