# CVE-2022-44566: Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter

> Attackers can cause denial of service in Rails applications by providing out-of-range integers to PostgreSQL adapters, triggering slow sequential scans.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2023
- **Updated:** 25 Mar 2025
- **Also known as:** DEBIAN-CVE-2022-44566, GHSA-579w-22j4-4749, SUSE-SU-2023:0492-1, SUSE-SU-2023:0518-1, SUSE-SU-2023:0587-1, UBUNTU-CVE-2022-44566

## What is CVE-2022-44566?

CVE-2022-44566 is a high-severity denial of service vulnerability in https://github.com/rails/rails, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1. When a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-44566?

4 open source packages ship an affected version, including activerecord. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | All versions | 6.1.7.1 |
| `activerecord` | RubyGems | All versions | 6.1.7.1 |
| `activerecord` | RubyGems | From 7.0.0 | 7.0.4.1 |
| `activerecord` | RubyGems | From 7.0.0 | 7.0.4.1 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-150000.5.6.1 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-150000.5.6.1 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-150000.5.6.1 |
| `rubygem-activerecord-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 5.1.4-150000.5.6.1 |
| `rubygem-activerecord-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-6.12.1 |
| `rubygem-activerecord-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-6.9.1 |
| `rubygem-activerecord-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-6.12.1 |
| `rubygem-activerecord-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-6.9.1 |
| `rubygem-activerecord-5_1` | openSUSE:Leap 15.4 | All versions | 5.1.4-150000.5.6.1 |

Products: Activerecord Project Activerecord.

## How do I fix CVE-2022-44566?

Upgrade activerecord to a fixed version for your release line: 6.1.7.1 or 7.0.4.1.

## Is CVE-2022-44566 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44566 exists.

## Other vulnerabilities in https://github.com/rails/rails

- [CVE-2022-32224](https://insights.sbomify.com/CVE-2022-32224/): Active Record RCE bug with Serialized Columns (critical 9.8)
- [CVE-2023-22794](https://insights.sbomify.com/CVE-2023-22794/): SQL Injection Vulnerability via ActiveRecord comments (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-44566 and fix it if it is affected.

What it is: CVE-2022-44566 is a high-severity denial of service vulnerability in https://github.com/rails/rails, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44566 exists.

Affected packages and fixed versions:
- activerecord (RubyGems): affected all versions; fixed in 6.1.7.1
- activerecord (RubyGems): affected all versions; fixed in 6.1.7.1
- activerecord (RubyGems): affected from 7.0.0; fixed in 7.0.4.1
- activerecord (RubyGems): affected from 7.0.0; fixed in 7.0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-44566/ (Markdown: https://insights.sbomify.com/CVE-2022-44566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-44566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-44566
- OSV: https://osv.dev/vulnerability/CVE-2022-44566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-44566/
Summaries are generated and may contain mistakes; the official description above is the record.
