# CVE-2022-44570: Denial of service via header parsing in Rack

> Attackers can cause denial of service in Rack-based applications by sending crafted Range headers that trigger excessive processing time.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2023
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-44570, GHSA-65f5-mfpf-vfhj, UBUNTU-CVE-2022-44570

## What is CVE-2022-44570?

CVE-2022-44570 is a high-severity denial of service vulnerability in https://github.com/rack/rack, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-44570?

8 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | From 1.5.0 | 2.0.9.2 |
| `rack` | RubyGems | From 1.5.0 | 2.0.9.2 |
| `rack` | RubyGems | From 2.1.0.0 | 2.1.4.2 |
| `rack` | RubyGems | From 2.1.0.0 | 2.1.4.2 |
| `rack` | RubyGems | From 2.2.0.0 | 2.2.6.2 |
| `rack` | RubyGems | From 2.2.0.0 | 2.2.6.2 |
| `rack` | RubyGems | From 3.0.0.0 | 3.0.4.1 |
| `rack` | RubyGems | From 3.0.0.0 | 3.0.4.1 |

Products: Rack Rack.

## How do I fix CVE-2022-44570?

Upgrade rack to a fixed version for your release line: 2.0.9.2, 2.1.4.2, 2.2.6.2 or 3.0.4.1.

## Is CVE-2022-44570 being exploited?

There is no known exploitation of CVE-2022-44570 in the wild and no public exploit code.

## Other vulnerabilities in https://github.com/rack/rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-44570 and fix it if it is affected.

What it is: CVE-2022-44570 is a high-severity denial of service vulnerability in https://github.com/rack/rack, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-44570 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected from 1.5.0; fixed in 2.0.9.2
- rack (RubyGems): affected from 1.5.0; fixed in 2.0.9.2
- rack (RubyGems): affected from 2.1.0.0; fixed in 2.1.4.2
- rack (RubyGems): affected from 2.1.0.0; fixed in 2.1.4.2
- rack (RubyGems): affected from 2.2.0.0; fixed in 2.2.6.2
- rack (RubyGems): affected from 2.2.0.0; fixed in 2.2.6.2
- rack (RubyGems): affected from 3.0.0.0; fixed in 3.0.4.1
- rack (RubyGems): affected from 3.0.0.0; fixed in 3.0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-44570/ (Markdown: https://insights.sbomify.com/CVE-2022-44570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-44570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-44570
- OSV: https://osv.dev/vulnerability/CVE-2022-44570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-44570/
Summaries are generated and may contain mistakes; the official description above is the record.
