CVE-2022-44637 Cross-site scripting in n/a
Persistent XSS in Redmine's Textile formatter allows attackers to inject scripts, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-44637?
CVE-2022-44637 is a medium-severity cross-site scripting vulnerability in Redmine Redmine, published on 12 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Redmine before 4.2.9 and 5.0.x before 5.0.4 allows persistent XSS in its Textile formatter due to improper sanitization in Redcloth3 Textile-formatted fields. Depending on the configuration, this may require login as a registered user.
Weakness: CWE-79
Which versions are affected by CVE-2022-44637?
1 open source package ship an affected version, including redmine. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
redmine Bitnami | All versions | 4.2.9, 5.0.4 |
Products include Redmine Redmine.
How do I fix CVE-2022-44637?
Upgrade redmine to a fixed version for your release line: 4.2.9 or 5.0.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-44637 being exploited?
There is no known exploitation of CVE-2022-44637 in the wild and no public exploit code.
Other vulnerabilities in Redmine Redmine
Sources
Also known as BIT-redmine-2022-44637, DEBIAN-CVE-2022-44637, GHSA-6839-6jhx-rcv7, UBUNTU-CVE-2022-44637.