CVE-2022-44729 Apache XML Graphics Batik: Information disclosure vulnerability
A malicious SVG can trigger external resource loading in Apache Batik, leading to information disclosure or resource consumption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-44729?
CVE-2022-44729 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 22 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16.
On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.
Weakness: CWE-918
Which versions are affected by CVE-2022-44729?
6 open source packages ship an affected version, including org.apache.xmlgraphics:batik-bridge, org.apache.xmlgraphics:batik-svgrasterizer and org.apache.xmlgraphics:batik-transcoder. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.xmlgraphics:batik-bridge Maven | From 1.0 | 1.17 |
org.apache.xmlgraphics:batik-bridge Maven | From 1.0 | 1.17 |
org.apache.xmlgraphics:batik-svgrasterizer Maven | From 1.0 | 1.17 |
org.apache.xmlgraphics:batik-svgrasterizer Maven | From 1.0 | 1.17 |
org.apache.xmlgraphics:batik-transcoder Maven | From 1.0 | 1.17 |
org.apache.xmlgraphics:batik-transcoder Maven | From 1.0 | 1.17 |
Products include Apache Xml Graphics Batik, Debian Debian Linux.
How do I fix CVE-2022-44729?
Upgrade org.apache.xmlgraphics:batik-bridge to 1.17 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2022-44729 being exploited?
There is no known exploitation of CVE-2022-44729 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLSA-2026-1780966324, DEBIAN-CVE-2022-44729, GHSA-gq5f-xv48-2365, UBUNTU-CVE-2022-44729.