# CVE-2022-44729: Apache XML Graphics Batik: Information disclosure vulnerability

> A malicious SVG can trigger external resource loading in Apache Batik, leading to information disclosure or resource consumption.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Aug 2023
- **Updated:** 8 Oct 2026
- **Also known as:** CLSA-2026-1780966324, DEBIAN-CVE-2022-44729, GHSA-gq5f-xv48-2365, UBUNTU-CVE-2022-44729

## What is CVE-2022-44729?

CVE-2022-44729 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 22 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16.

On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-44729?

6 open source packages ship an affected version, including org.apache.xmlgraphics:batik-bridge, org.apache.xmlgraphics:batik-svgrasterizer and org.apache.xmlgraphics:batik-transcoder. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.xmlgraphics:batik-bridge` | Maven | From 1.0 | 1.17 |
| `org.apache.xmlgraphics:batik-bridge` | Maven | From 1.0 | 1.17 |
| `org.apache.xmlgraphics:batik-svgrasterizer` | Maven | From 1.0 | 1.17 |
| `org.apache.xmlgraphics:batik-svgrasterizer` | Maven | From 1.0 | 1.17 |
| `org.apache.xmlgraphics:batik-transcoder` | Maven | From 1.0 | 1.17 |
| `org.apache.xmlgraphics:batik-transcoder` | Maven | From 1.0 | 1.17 |

Products: Apache Xml Graphics Batik, Debian Debian Linux.

## How do I fix CVE-2022-44729?

Upgrade org.apache.xmlgraphics:batik-bridge to 1.17 or later.

## Is CVE-2022-44729 being exploited?

There is no known exploitation of CVE-2022-44729 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2022-44730](https://insights.sbomify.com/CVE-2022-44730/): Apache XML Graphics Batik: Information disclosure vulnerability (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-44729 and fix it if it is affected.

What it is: CVE-2022-44729 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 22 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-44729 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.xmlgraphics:batik-bridge (Maven): affected from 1.0; fixed in 1.17
- org.apache.xmlgraphics:batik-bridge (Maven): affected from 1.0; fixed in 1.17
- org.apache.xmlgraphics:batik-svgrasterizer (Maven): affected from 1.0; fixed in 1.17
- org.apache.xmlgraphics:batik-svgrasterizer (Maven): affected from 1.0; fixed in 1.17
- org.apache.xmlgraphics:batik-transcoder (Maven): affected from 1.0; fixed in 1.17
- org.apache.xmlgraphics:batik-transcoder (Maven): affected from 1.0; fixed in 1.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-44729/ (Markdown: https://insights.sbomify.com/CVE-2022-44729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-44729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-44729
- OSV: https://osv.dev/vulnerability/CVE-2022-44729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-44729/
Summaries are generated and may contain mistakes; the official description above is the record.
