# CVE-2022-4477: Smash Balloon Social Post Feed < 4.1.6 - Contributor+ Stored XSS

> Contributors can inject malicious scripts via shortcode attributes, leading to stored XSS attacks against logged-in administrators.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Jan 2023
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-w6fg-m72j-wggm

## What is CVE-2022-4477?

CVE-2022-4477 is a medium-severity cross-site scripting vulnerability in Unknown Smash Balloon Social Post Feed, published on 16 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Smash Balloon Social Post Feed WordPress plugin before 4.1.6 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks against logged-in admins.

## Which versions are affected by CVE-2022-4477?

It affects 1 product.


Products: Smashballoon Smash Balloon Social Post Feed.

## How do I fix CVE-2022-4477?

No fix has been published for CVE-2022-4477 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4477 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4477 exists.

## Other vulnerabilities in Unknown Smash Balloon Social Post Feed

- [CVE-2021-24508](https://insights.sbomify.com/CVE-2021-24508/): Smash Balloon Social Post Feed < 2.19.2 - Unauthenticated Stored XSS (medium 6.1)
- [CVE-2021-25065](https://insights.sbomify.com/CVE-2021-25065/): Smash Balloon Social Post Feed < 4.1.1 - Authenticated Reflected Cross-Site Scripting (XSS) (medium 5.4)
- [CVE-2021-24918](https://insights.sbomify.com/CVE-2021-24918/): Smash Balloon Social Post Feed < 4.0.1 - Subscriber+ Arbitrary Plugin Settings Update to Stored XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4477 and fix it if it is affected.

What it is: CVE-2022-4477 is a medium-severity cross-site scripting vulnerability in Unknown Smash Balloon Social Post Feed, published on 16 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4477 exists.

Affected product: Unknown Smash Balloon Social Post Feed. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4477/ (Markdown: https://insights.sbomify.com/CVE-2022-4477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4477
- OSV: https://osv.dev/vulnerability/CVE-2022-4477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4477/
Summaries are generated and may contain mistakes; the official description above is the record.
