# CVE-2022-44900: py7zr directory traversal vulnerability

> Attackers can write arbitrary files to the filesystem by extracting a crafted 7z archive using the py7zr library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-44900, DSA-5652-1, GHSA-m8xw-9x5x-6vh3, PYSEC-2022-42998, UBUNTU-CVE-2022-44900, USN-7030-1, openSUSE-SU-2024:12586-1, openSUSE-SU-2025:15101-1

## What is CVE-2022-44900?

CVE-2022-44900 is a critical path traversal vulnerability in n/a, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A directory traversal vulnerability in the SevenZipFile.extractall() function of the python library py7zr v0.20.0 and earlier allows attackers to write arbitrary files via extracting a crafted 7z file.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-44900?

3 open source packages ship an affected version, including py7zr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `py7zr` | PyPI | All versions | 0.20.1 |
| `py7zr` | PyPI | All versions | 0.20.1 |
| `py7zr` | PyPI | All versions | 0.20.1 |
| `python-py7zr` | openSUSE:Tumbleweed | All versions | 0.20.8-2.6 |

Products: Py7zr Project Py7zr.

## How do I fix CVE-2022-44900?

Upgrade py7zr to 0.20.1 or later.

## Is CVE-2022-44900 being exploited?

There is no known exploitation of CVE-2022-44900 in the wild and no public exploit code.

Public exploit code:

- Demo webapp vulnerable to CVE-2022-44900 (github_poc): https://github.com/0xless/CVE-2022-44900-demo-lab

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-44900 and fix it if it is affected.

What it is: CVE-2022-44900 is a critical path traversal vulnerability in n/a, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-44900 in the wild and no public exploit code.

Affected packages and fixed versions:
- py7zr (PyPI): affected all versions; fixed in 0.20.1
- py7zr (PyPI): affected all versions; fixed in 0.20.1
- py7zr (PyPI): affected all versions; fixed in 0.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-44900/ (Markdown: https://insights.sbomify.com/CVE-2022-44900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-44900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-44900
- OSV: https://osv.dev/vulnerability/CVE-2022-44900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-44900/
Summaries are generated and may contain mistakes; the official description above is the record.
