{"answers":{"affected":"4 open source packages ship an affected version, including patchelf and pypatchelf. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44940 exists.","fix":"Upgrade patchelf to 0.16.1.0 or later.","what":"CVE-2022-44940 is a critical memory corruption vulnerability in n/a, published on 19 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-44940 and fix it if it is affected.\n\nWhat it is: CVE-2022-44940 is a critical memory corruption vulnerability in n/a, published on 19 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44940 exists.\n\nAffected packages and fixed versions:\n- patchelf (PyPI): affected all versions; fixed in 0.16.1.0\n- patchelf (PyPI): affected all versions; fixed in 0.16.1.0\n- patchelf (PyPI): affected all versions; fixed in 0.16.1.0\n- pypatchelf (PyPI): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-44940/ (Markdown: https://insights.sbomify.com/CVE-2022-44940/index.md)","id":"CVE-2022-44940","markdown":"https://insights.sbomify.com/CVE-2022-44940/index.md","name":"CVE-2022-44940","record":{"aliases":["DEBIAN-CVE-2022-44940","ECHO-cf23-5ff7-f083","GHSA-5pcj-3m26-w633","MGASA-2023-0179","OESA-2023-1001","PYSEC-2022-43144","PYSEC-2022-43151","UBUNTU-CVE-2022-44940","USN-6036-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Patchelf binary tool","requires_auth":"none","summary":"An out-of-bounds read in Patchelf allows attackers to cause denial of service or disclose sensitive memory contents via crafted binaries.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"patchelf","vendor":"patchelf_project"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Patchelf v0.9 was discovered to contain an out-of-bounds read via the function modifyRPath at src/patchelf.cc.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Patchelf out-of-bounds read","id":"CVE-2022-44940","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"Casdoor arbitrary file deletion vulnerability via uploadFile function","id":"CVE-2022-44942"},"packages":[{"ecosystem":"PyPI","fixed":["0.16.1.0"],"introduced":["0"],"last_affected":[],"package":"patchelf","purl":null,"source":"GHSA-5pcj-3m26-w633"},{"ecosystem":"PyPI","fixed":["0.16.1.0"],"introduced":["0"],"last_affected":[],"package":"patchelf","purl":"pkg:pypi/patchelf","source":"GHSA-5pcj-3m26-w633"},{"ecosystem":"PyPI","fixed":["0.16.1.0"],"introduced":["0"],"last_affected":[],"package":"patchelf","purl":"pkg:pypi/patchelf","source":"PYSEC-2022-43144"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":[],"package":"pypatchelf","purl":"pkg:pypi/pypatchelf","source":"PYSEC-2022-43151"}],"prev":{"headline":"Other in n/a","id":"CVE-2022-44939"},"products":["n/a"],"published":"2022-12-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["n/a"]},"summary":"An out-of-bounds read in Patchelf allows attackers to cause denial of service or disclose sensitive memory contents via crafted binaries.","url":"https://insights.sbomify.com/CVE-2022-44940/"}