# CVE-2022-44940: Patchelf out-of-bounds read

> An out-of-bounds read in Patchelf allows attackers to cause denial of service or disclose sensitive memory contents via crafted binaries.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2022
- **Updated:** 17 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-44940, ECHO-cf23-5ff7-f083, GHSA-5pcj-3m26-w633, MGASA-2023-0179, OESA-2023-1001, PYSEC-2022-43144, PYSEC-2022-43151, UBUNTU-CVE-2022-44940, USN-6036-1

## What is CVE-2022-44940?

CVE-2022-44940 is a critical memory corruption vulnerability in n/a, published on 19 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Patchelf v0.9 was discovered to contain an out-of-bounds read via the function modifyRPath at src/patchelf.cc.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-44940?

4 open source packages ship an affected version, including patchelf and pypatchelf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `patchelf` | PyPI | All versions | 0.16.1.0 |
| `patchelf` | PyPI | All versions | 0.16.1.0 |
| `patchelf` | PyPI | All versions | 0.16.1.0 |
| `pypatchelf` | PyPI | All versions | None |

Products: Patchelf Project Patchelf.

## How do I fix CVE-2022-44940?

Upgrade patchelf to 0.16.1.0 or later.

## Is CVE-2022-44940 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44940 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-44940 and fix it if it is affected.

What it is: CVE-2022-44940 is a critical memory corruption vulnerability in n/a, published on 19 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-44940 exists.

Affected packages and fixed versions:
- patchelf (PyPI): affected all versions; fixed in 0.16.1.0
- patchelf (PyPI): affected all versions; fixed in 0.16.1.0
- patchelf (PyPI): affected all versions; fixed in 0.16.1.0
- pypatchelf (PyPI): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-44940/ (Markdown: https://insights.sbomify.com/CVE-2022-44940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-44940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-44940
- OSV: https://osv.dev/vulnerability/CVE-2022-44940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-44940/
Summaries are generated and may contain mistakes; the official description above is the record.
