# CVE-2022-4495: collective.dms.basecontent column.py renderCell cross site scripting

> Remote attackers can execute arbitrary scripts via cross-site scripting in the renderCell function of collective.dms.basecontent.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-r48c-4vfj-h426, PYSEC-2022-42989

## What is CVE-2022-4495?

CVE-2022-4495 is a low-severity cross-site scripting vulnerability in collective.dms.basecontent, published on 14 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in collective.dms.basecontent up to 1.6. This issue affects the function renderCell of the file src/collective/dms/basecontent/browser/column.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.7 is able to address this issue. The name of the patch is 6c4d616fcc771822a14ebae5e23f3f6d96d134bd. It is recommended to upgrade the affected component. The identifier VDB-215813 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4495?

3 open source packages ship an affected version, including collective.dms.basecontent and collective-dms-basecontent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `collective.dms.basecontent` | PyPI | All versions | 1.7 |
| `collective-dms-basecontent` | PyPI | All versions | 1.7 |
| `collective-dms-basecontent` | PyPI | All versions | 1.7 |

Products: Collective.dms.basecontent Project Collective.dms.basecontent.

## How do I fix CVE-2022-4495?

Upgrade collective.dms.basecontent to 1.7 or later.

## Is CVE-2022-4495 being exploited?

There is no known exploitation of CVE-2022-4495 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4495 and fix it if it is affected.

What it is: CVE-2022-4495 is a low-severity cross-site scripting vulnerability in collective.dms.basecontent, published on 14 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4495 in the wild and no public exploit code.

Affected packages and fixed versions:
- collective.dms.basecontent (PyPI): affected all versions; fixed in 1.7
- collective-dms-basecontent (PyPI): affected all versions; fixed in 1.7
- collective-dms-basecontent (PyPI): affected all versions; fixed in 1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4495/ (Markdown: https://insights.sbomify.com/CVE-2022-4495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4495
- OSV: https://osv.dev/vulnerability/CVE-2022-4495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4495/
Summaries are generated and may contain mistakes; the official description above is the record.
