CVE-2022-45048 Apache Ranger: code execution vulnerability in policy expressions

High 8.4 Published Updated

Authenticated users with privileges can execute arbitrary code via malicious policy expressions in Apache Ranger.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-45048?

CVE-2022-45048 is a high-severity code injection vulnerability in Apache Ranger, published on 5 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution vulnerability. This issue affects Apache Ranger: 2.3.0. Users are recommended to update to version 2.4.0.

Weakness: CWE-74

Which versions are affected by CVE-2022-45048?

2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.

PackageAffectedFixed in
org.apache.ranger:ranger MavenFrom 2.3.02.4.0
org.apache.ranger:ranger MavenFrom 2.3.02.4.0

Products include Apache Ranger.

How do I fix CVE-2022-45048?

Upgrade org.apache.ranger:ranger to 2.4.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2022-45048 being exploited?

There is no known exploitation of CVE-2022-45048 in the wild and no public exploit code.

Sources

Also known as GHSA-89gw-cffj-mqg9.

Is CVE-2022-45048 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free