# CVE-2022-45048: Apache Ranger: code execution vulnerability in policy expressions

> Authenticated users with privileges can execute arbitrary code via malicious policy expressions in Apache Ranger.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2023
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-89gw-cffj-mqg9

## What is CVE-2022-45048?

CVE-2022-45048 is a high-severity code injection vulnerability in Apache Ranger, published on 5 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution vulnerability. This issue affects Apache Ranger: 2.3.0. Users are recommended to update to version 2.4.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-45048?

2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ranger:ranger` | Maven | From 2.3.0 | 2.4.0 |
| `org.apache.ranger:ranger` | Maven | From 2.3.0 | 2.4.0 |

Products: Apache Ranger.

## How do I fix CVE-2022-45048?

Upgrade org.apache.ranger:ranger to 2.4.0 or later.

## Is CVE-2022-45048 being exploited?

There is no known exploitation of CVE-2022-45048 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ranger

- [CVE-2026-28672](https://insights.sbomify.com/CVE-2026-28672/): Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder (critical 9.8)
- [CVE-2026-32227](https://insights.sbomify.com/CVE-2026-32227/): Apache Ranger: SQL Injection vulnerability in lookup functionality (critical 9.8)
- [CVE-2026-40920](https://insights.sbomify.com/CVE-2026-40920/): Apache Ranger: Privilege Escalation via URL Parameter (critical 9.8)
- [CVE-2026-42537](https://insights.sbomify.com/CVE-2026-42537/): Apache Ranger: Remote Code Execution via JDBC URL Injection (critical 9.8)
- [CVE-2026-44416](https://insights.sbomify.com/CVE-2026-44416/): Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45048 and fix it if it is affected.

What it is: CVE-2022-45048 is a high-severity code injection vulnerability in Apache Ranger, published on 5 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-45048 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ranger:ranger (Maven): affected from 2.3.0; fixed in 2.4.0
- org.apache.ranger:ranger (Maven): affected from 2.3.0; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45048/ (Markdown: https://insights.sbomify.com/CVE-2022-45048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45048
- OSV: https://osv.dev/vulnerability/CVE-2022-45048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45048/
Summaries are generated and may contain mistakes; the official description above is the record.
