{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.engine. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-45064 in the wild and no public exploit code.","fix":"Upgrade org.apache.sling:org.apache.sling.engine to 2.14.0 or later.","what":"CVE-2022-45064 is a high-severity cross-site scripting vulnerability in Apache Sling Engine, published on 13 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-45064 and fix it if it is affected.\n\nWhat it is: CVE-2022-45064 is a high-severity cross-site scripting vulnerability in Apache Sling Engine, published on 13 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-45064 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.sling:org.apache.sling.engine (Maven): affected all versions; fixed in 2.14.0\n- org.apache.sling:org.apache.sling.engine (Maven): affected all versions; fixed in 2.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-45064/ (Markdown: https://insights.sbomify.com/CVE-2022-45064/index.md)","id":"CVE-2022-45064","markdown":"https://insights.sbomify.com/CVE-2022-45064/index.md","name":"CVE-2022-45064","record":{"aliases":["GHSA-mg46-f9h5-g27x"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Sling Engine","requires_auth":"low_privilege","summary":"An attacker can perform include-based XSS to escalate privileges to administrative power in Apache Sling Engine.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache_sling_engine","vendor":"apache"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power.\n\nPlease update to Apache Sling Engine \u003e= 2.14.0 and enable the \"Check Content-Type overrides\" configuration option.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Sling Engine: Include-based XSS","id":"CVE-2022-45064","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"WordPress SEO Plugin by Squirrly SEO Plugin \u003c= 12.1.20 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2022-45065"},"packages":[{"ecosystem":"Maven","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.engine","purl":null,"source":"GHSA-mg46-f9h5-g27x"},{"ecosystem":"Maven","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.engine","purl":"pkg:maven/org.apache.sling/org.apache.sling.engine","source":"GHSA-mg46-f9h5-g27x"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2022-45063"},"products":["Apache Sling Engine"],"published":"2023-04-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-17","vendors":["Apache Software Foundation"]},"summary":"An attacker can perform include-based XSS to escalate privileges to administrative power in Apache Sling Engine.","url":"https://insights.sbomify.com/CVE-2022-45064/"}