# CVE-2022-45129: Payara, when deployed to the root context, allows attackers to visit META-INF and WEB-INF

> Attackers can access sensitive META-INF and WEB-INF directories when Payara is deployed to the root context, leading to information disclosure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2022
- **Updated:** 1 May 2025
- **Also known as:** GHSA-q35w-85pq-rv3x

## What is CVE-2022-45129?

CVE-2022-45129 is a high-severity vulnerability in n/a, published on 10 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Payara before 2022-11-04, when deployed to the root context, allows attackers to visit META-INF and WEB-INF, a different vulnerability than CVE-2022-37422. This affects Payara Platform Community before 4.1.2.191.38, 5.x before 5.2022.4, and 6.x before 6.2022.1, and Payara Platform Enterprise before 5.45.0.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2022-45129?

6 open source packages ship an affected version, including fish.payara.distributions:payara. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fish.payara.distributions:payara` | Maven | All versions to 4.1.2.181 | None |
| `fish.payara.distributions:payara` | Maven | All versions to 4.1.2.181 | None |
| `fish.payara.distributions:payara` | Maven | From 5.0.0.Alpha1 | 5.2022.5 |
| `fish.payara.distributions:payara` | Maven | From 5.0.0.Alpha1 | 5.2022.5 |
| `fish.payara.distributions:payara` | Maven | From 6.2021.1.Alpha1 | 6.2022.2 |
| `fish.payara.distributions:payara` | Maven | From 6.2021.1.Alpha1 | 6.2022.2 |

Products: Payara Payara.

## How do I fix CVE-2022-45129?

Upgrade fish.payara.distributions:payara to a fixed version for your release line: 5.2022.5 or 6.2022.2.

## Is CVE-2022-45129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45129 exists.

## Other vulnerabilities in n/a

- [CVE-2024-8215](https://insights.sbomify.com/CVE-2024-8215/): Payload Injection Attack via Management REST interface (high 8.7)
- [CVE-2022-37422](https://insights.sbomify.com/CVE-2022-37422/): Path Traversal in Payara (high 7.5)
- [CVE-2024-7312](https://insights.sbomify.com/CVE-2024-7312/): REST Interface Link Redirection via Host parameter (high 7.0)
- [CVE-2025-1534](https://insights.sbomify.com/CVE-2025-1534/): Cross-site Scripting (Stored) (medium 6.8)
- [CVE-2023-41699](https://insights.sbomify.com/CVE-2023-41699/): Payara Platform: URL Redirection to untrusted site using FORM authentication (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45129 and fix it if it is affected.

What it is: CVE-2022-45129 is a high-severity vulnerability in n/a, published on 10 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45129 exists.

Affected packages and fixed versions:
- fish.payara.distributions:payara (Maven): affected all versions up to 4.1.2.181; no fix listed
- fish.payara.distributions:payara (Maven): affected all versions up to 4.1.2.181; no fix listed
- fish.payara.distributions:payara (Maven): affected from 5.0.0.Alpha1; fixed in 5.2022.5
- fish.payara.distributions:payara (Maven): affected from 5.0.0.Alpha1; fixed in 5.2022.5
- fish.payara.distributions:payara (Maven): affected from 6.2021.1.Alpha1; fixed in 6.2022.2
- fish.payara.distributions:payara (Maven): affected from 6.2021.1.Alpha1; fixed in 6.2022.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45129/ (Markdown: https://insights.sbomify.com/CVE-2022-45129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45129
- OSV: https://osv.dev/vulnerability/CVE-2022-45129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45129/
Summaries are generated and may contain mistakes; the official description above is the record.
