CVE-2022-45135 Apache Cocoon: SQL injection in DatabaseCookieAuthenticatorAction

Critical 9.8 Published Updated

Attackers can execute arbitrary SQL commands via the DatabaseCookieAuthenticatorAction in Apache Cocoon, potentially compromising database integrity and confidentiality.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-45135?

CVE-2022-45135 is a critical SQL injection vulnerability in Apache Cocoon, published on 30 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Cocoon.This issue affects Apache Cocoon: from 2.2.0 before 2.3.0.

Users are recommended to upgrade to version 2.3.0, which fixes the issue.

Weakness: CWE-89

Which versions are affected by CVE-2022-45135?

2 open source packages ship an affected version, including org.apache.cocoon:cocoon. It affects 1 product.

PackageAffectedFixed in
org.apache.cocoon:cocoon MavenFrom 2.2.02.3.0
org.apache.cocoon:cocoon MavenFrom 2.2.02.3.0

Products include Apache Cocoon.

How do I fix CVE-2022-45135?

Upgrade org.apache.cocoon:cocoon to 2.3.0 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2022-45135 being exploited?

There is no known exploitation of CVE-2022-45135 in the wild and no public exploit code.

Sources

Also known as GHSA-8v4w-jr33-4rh3.

Is CVE-2022-45135 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free