{"answers":{"affected":"3 open source packages ship an affected version, including hyperledger-fabric-orderer, hyperledger-fabric-peer and hyperledger-fabric-tools. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-45196 in the wild and no public exploit code.","fix":"Upgrade hyperledger-fabric-orderer to 2.3.1 or later.","what":"CVE-2022-45196 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-45196 and fix it if it is affected.\n\nWhat it is: CVE-2022-45196 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-45196 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hyperledger-fabric-orderer (Bitnami): affected from 2.3.0; fixed in 2.3.1\n- hyperledger-fabric-peer (Bitnami): affected from 2.3.0; fixed in 2.3.1\n- hyperledger-fabric-tools (Bitnami): affected from 2.3.0; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-45196/ (Markdown: https://insights.sbomify.com/CVE-2022-45196/index.md)","id":"CVE-2022-45196","markdown":"https://insights.sbomify.com/CVE-2022-45196/index.md","name":"CVE-2022-45196","record":{"aliases":["BIT-hyperledger-fabric-orderer-2022-45196","BIT-hyperledger-fabric-peer-2022-45196","BIT-hyperledger-fabric-tools-2022-45196","GHSA-wp68-67c6-87fh"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Hyperledger Fabric orderer","requires_auth":"none","summary":"Attackers can crash the Hyperledger Fabric orderer by repeatedly sending crafted channel transactions with duplicate names, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fabric","vendor":"hyperledger"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-670","name":"Always-Incorrect Control Flow Implementation"}],"description":"Hyperledger Fabric 2.3 allows attackers to cause a denial of service (orderer crash) by repeatedly sending a crafted channel tx with the same Channel name. NOTE: the official Fabric with Raft prevents exploitation via a locking mechanism and a check for names that already exist.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-45196","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Slixmpp lacks SSL Certificate hostname validation in XMLStream","id":"CVE-2022-45197"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.1"],"introduced":["2.3.0"],"last_affected":[],"package":"hyperledger-fabric-orderer","purl":"pkg:bitnami/hyperledger-fabric-orderer","source":"BIT-hyperledger-fabric-orderer-2022-45196"},{"ecosystem":"Bitnami","fixed":["2.3.1"],"introduced":["2.3.0"],"last_affected":[],"package":"hyperledger-fabric-peer","purl":"pkg:bitnami/hyperledger-fabric-peer","source":"BIT-hyperledger-fabric-peer-2022-45196"},{"ecosystem":"Bitnami","fixed":["2.3.1"],"introduced":["2.3.0"],"last_affected":[],"package":"hyperledger-fabric-tools","purl":"pkg:bitnami/hyperledger-fabric-tools","source":"BIT-hyperledger-fabric-tools-2022-45196"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2022-45195"},"products":["n/a"],"published":"2022-11-12","related":[{"cvss_score":9.3,"headline":"ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE","id":"CVE-2026-41586","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"Improper Input Validation in fabric hyperledger","id":"CVE-2022-31121","kev_date_added":null,"published":"2022-07-07"},{"cvss_score":7.1,"headline":"Crosslinking transaction attack in hyperledger/fabric","id":"CVE-2023-46132","kev_date_added":null,"published":"2023-11-14"},{"cvss_score":7,"headline":"Remote denial of service in Hyperledger Fabric Gateway","id":"CVE-2022-36023","kev_date_added":null,"published":"2022-08-18"},{"cvss_score":5.3,"headline":"Hyperledger Fabric does not verify request has a timestamp within the expected time window","id":"CVE-2024-45244","kev_date_added":null,"published":"2024-08-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-01","vendors":["n/a"]},"summary":"Attackers can crash the Hyperledger Fabric orderer by repeatedly sending crafted channel transactions with duplicate names, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2022-45196/"}