# CVE-2022-45196: Denial of service in n/a

> Attackers can crash the Hyperledger Fabric orderer by repeatedly sending crafted channel transactions with duplicate names, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2022
- **Updated:** 1 May 2025
- **Also known as:** BIT-hyperledger-fabric-orderer-2022-45196, BIT-hyperledger-fabric-peer-2022-45196, BIT-hyperledger-fabric-tools-2022-45196, GHSA-wp68-67c6-87fh

## What is CVE-2022-45196?

CVE-2022-45196 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hyperledger Fabric 2.3 allows attackers to cause a denial of service (orderer crash) by repeatedly sending a crafted channel tx with the same Channel name. NOTE: the official Fabric with Raft prevents exploitation via a locking mechanism and a check for names that already exist.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2022-45196?

3 open source packages ship an affected version, including hyperledger-fabric-orderer, hyperledger-fabric-peer and hyperledger-fabric-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hyperledger-fabric-orderer` | Bitnami | From 2.3.0 | 2.3.1 |
| `hyperledger-fabric-peer` | Bitnami | From 2.3.0 | 2.3.1 |
| `hyperledger-fabric-tools` | Bitnami | From 2.3.0 | 2.3.1 |

Products: Hyperledger Fabric.

## How do I fix CVE-2022-45196?

Upgrade hyperledger-fabric-orderer to 2.3.1 or later.

## Is CVE-2022-45196 being exploited?

There is no known exploitation of CVE-2022-45196 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-41586](https://insights.sbomify.com/CVE-2026-41586/): ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE (critical 9.3)
- [CVE-2022-31121](https://insights.sbomify.com/CVE-2022-31121/): Improper Input Validation in fabric hyperledger (high 7.5)
- [CVE-2023-46132](https://insights.sbomify.com/CVE-2023-46132/): Crosslinking transaction attack in hyperledger/fabric (high 7.1)
- [CVE-2022-36023](https://insights.sbomify.com/CVE-2022-36023/): Remote denial of service in Hyperledger Fabric Gateway (high 7.0)
- [CVE-2024-45244](https://insights.sbomify.com/CVE-2024-45244/): Hyperledger Fabric does not verify request has a timestamp within the expected time window (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45196 and fix it if it is affected.

What it is: CVE-2022-45196 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-45196 in the wild and no public exploit code.

Affected packages and fixed versions:
- hyperledger-fabric-orderer (Bitnami): affected from 2.3.0; fixed in 2.3.1
- hyperledger-fabric-peer (Bitnami): affected from 2.3.0; fixed in 2.3.1
- hyperledger-fabric-tools (Bitnami): affected from 2.3.0; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45196/ (Markdown: https://insights.sbomify.com/CVE-2022-45196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45196
- OSV: https://osv.dev/vulnerability/CVE-2022-45196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45196/
Summaries are generated and may contain mistakes; the official description above is the record.
