# CVE-2022-45198: Pillow vulnerable to Data Amplification attack.

> Attackers can cause denial of service by providing highly compressed GIF files that trigger data amplification in the Pillow library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-pillow-2022-45198, DEBIAN-CVE-2022-45198, GHSA-m2vv-5vj5-2hm7, OESA-2023-1923, PYSEC-2022-42979, ROOT-APP-PYPI-CVE-2022-45198, SUSE-SU-2024:2908-1, UBUNTU-CVE-2022-45198, openSUSE-SU-2024:0253-1

## What is CVE-2022-45198?

CVE-2022-45198 is a high-severity denial of service vulnerability in Python Pillow, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow before 9.2.0 performs Improper Handling of Highly Compressed GIF Data (Data Amplification).

## Which versions are affected by CVE-2022-45198?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 9.2.0 |
| `pillow` | PyPI | All versions | 9.2.0 |
| `pillow` | PyPI | All versions | 9.2.0 |
| `pillow` | PyPI | All versions | 9.2.0 |
| `python-Pillow` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 7.2.0-150300.3.18.1 |
| `python-Pillow` | SUSE:Package Hub 15 SP5 | All versions | 8.4.0-bp155.3.9.1 |
| `python-Pillow` | openSUSE:Leap 15.5 | All versions | 7.2.0-150300.3.18.1 |
| `python-Pillow` | openSUSE:Leap 15.5 | All versions | 8.4.0-bp155.3.9.1 |

Products: Python Pillow.

## How do I fix CVE-2022-45198?

Upgrade pillow to 9.2.0 or later.

## Is CVE-2022-45198 being exploited?

There is no known exploitation of CVE-2022-45198 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45198 and fix it if it is affected.

What it is: CVE-2022-45198 is a high-severity denial of service vulnerability in Python Pillow, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-45198 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 9.2.0
- pillow (PyPI): affected all versions; fixed in 9.2.0
- pillow (PyPI): affected all versions; fixed in 9.2.0
- pillow (PyPI): affected all versions; fixed in 9.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45198/ (Markdown: https://insights.sbomify.com/CVE-2022-45198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45198
- OSV: https://osv.dev/vulnerability/CVE-2022-45198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45198/
Summaries are generated and may contain mistakes; the official description above is the record.
