CVE-2022-4520 WSO2 carbon-registry Advanced Search advancedSearchForm-ajaxprocessor.jsp cross site scripting

Low 3.5 Published Updated

Remote attackers can inject malicious scripts via Advanced Search parameters in WSO2 carbon-registry, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-4520?

CVE-2022-4520 is a low-severity cross-site scripting vulnerability in WSO2 carbon-registry, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in WSO2 carbon-registry up to 4.8.11. It has been rated as problematic. Affected by this issue is some unknown functionality of the file components/registry/org.wso2.carbon.registry.search.ui/src/main/resources/web/search/advancedSearchForm-ajaxprocessor.jsp of the component Advanced Search. The manipulation of the argument mediaType/rightOp/leftOp/rightPropertyValue/leftPropertyValue leads to cross site scripting. The attack may be launched remotely. Upgrading to version 4.8.12 is able to address this issue. The name of the patch is 0c827cc1b14b82d8eb86117ab2e43c34bb91ddb4. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215900.

Weakness: CWE-79, CWE-707

Which versions are affected by CVE-2022-4520?

2 open source packages ship an affected version, including org.wso2.carbon.registry:carbon-registry. It affects 1 product.

PackageAffectedFixed in
org.wso2.carbon.registry:carbon-registry MavenAll versions4.8.12
org.wso2.carbon.registry:carbon-registry MavenAll versions4.8.12

Products include Wso2 Carbon-Registry.

How do I fix CVE-2022-4520?

Upgrade org.wso2.carbon.registry:carbon-registry to 4.8.12 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-4520 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4520 exists.

Sources

Also known as GHSA-j34r-57xj-pfm5.

Is CVE-2022-4520 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free