{"answers":{"affected":"2 open source packages ship an affected version, including org.wso2.carbon.registry:carbon-registry. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4520 exists.","fix":"Upgrade org.wso2.carbon.registry:carbon-registry to 4.8.12 or later.","what":"CVE-2022-4520 is a low-severity cross-site scripting vulnerability in WSO2 carbon-registry, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4520 and fix it if it is affected.\n\nWhat it is: CVE-2022-4520 is a low-severity cross-site scripting vulnerability in WSO2 carbon-registry, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4520 exists.\n\nAffected packages and fixed versions:\n- org.wso2.carbon.registry:carbon-registry (Maven): affected all versions; fixed in 4.8.12\n- org.wso2.carbon.registry:carbon-registry (Maven): affected all versions; fixed in 4.8.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4520/ (Markdown: https://insights.sbomify.com/CVE-2022-4520/index.md)","id":"CVE-2022-4520","markdown":"https://insights.sbomify.com/CVE-2022-4520/index.md","name":"CVE-2022-4520","record":{"aliases":["GHSA-j34r-57xj-pfm5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WSO2 carbon-registry","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via Advanced Search parameters in WSO2 carbon-registry, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"carbon-registry","vendor":"wso2"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability was found in WSO2 carbon-registry up to 4.8.11. It has been rated as problematic. Affected by this issue is some unknown functionality of the file components/registry/org.wso2.carbon.registry.search.ui/src/main/resources/web/search/advancedSearchForm-ajaxprocessor.jsp of the component Advanced Search. The manipulation of the argument mediaType/rightOp/leftOp/rightPropertyValue/leftPropertyValue leads to cross site scripting. The attack may be launched remotely. Upgrading to version 4.8.12 is able to address this issue. The name of the patch is 0c827cc1b14b82d8eb86117ab2e43c34bb91ddb4. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215900.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"WSO2 carbon-registry Advanced Search advancedSearchForm-ajaxprocessor.jsp cross site scripting","id":"CVE-2022-4520","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"WSO2 carbon-registry Request Parameter cross site scripting","id":"CVE-2022-4521"},"packages":[{"ecosystem":"Maven","fixed":["4.8.12"],"introduced":["0"],"last_affected":[],"package":"org.wso2.carbon.registry:carbon-registry","purl":null,"source":"GHSA-j34r-57xj-pfm5"},{"ecosystem":"Maven","fixed":["4.8.12"],"introduced":["0"],"last_affected":[],"package":"org.wso2.carbon.registry:carbon-registry","purl":"pkg:maven/org.wso2.carbon.registry/carbon-registry","source":"GHSA-j34r-57xj-pfm5"}],"prev":{"headline":"WP User \u003c= 7.0 - Authenticated (Administrator+) Stored Cross-Site Scripting","id":"CVE-2022-4519"},"products":["carbon-registry"],"published":"2022-12-15","related":[{"cvss_score":3.5,"headline":"WSO2 carbon-registry Request Parameter cross site scripting","id":"CVE-2022-4521","kev_date_added":null,"published":"2022-12-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["WSO2"]},"summary":"Remote attackers can inject malicious scripts via Advanced Search parameters in WSO2 carbon-registry, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2022-4520/"}