# CVE-2022-4522: CalendarXP cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 15 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-rpqp-56j6-6mjp

## What is CVE-2022-4522?

CVE-2022-4522 is a low-severity vulnerability in unspecified CalendarXP, published on 15 Dec 2022. 

### Official description

A vulnerability classified as problematic was found in CalendarXP up to 10.0.1. This vulnerability affects unknown code. The manipulation leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 10.0.2 is able to address this issue. The name of the patch is e3715b2228ddefe00113296069969f9e184836da. It is recommended to upgrade the affected component. VDB-215902 is the identifier assigned to this vulnerability.

Weakness: CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-4522?

It affects 1 product.


Products: Calendarxp Calendarxp.

## How do I fix CVE-2022-4522?

No fix has been published for CVE-2022-4522 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4522 being exploited?

There is no known exploitation of CVE-2022-4522 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4522 and fix it if it is affected.

What it is: CVE-2022-4522 is a low-severity vulnerability in unspecified CalendarXP, published on 15 Dec 2022. 
Exploitation: There is no known exploitation of CVE-2022-4522 in the wild and no public exploit code.

Affected product: unspecified CalendarXP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4522/ (Markdown: https://insights.sbomify.com/CVE-2022-4522/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4522
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4522
- OSV: https://osv.dev/vulnerability/CVE-2022-4522

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4522/
Summaries are generated and may contain mistakes; the official description above is the record.
