{"answers":{"affected":"2 open source packages ship an affected version, including roots/soil. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4524 in the wild and no public exploit code.","fix":"Upgrade roots/soil to 4.1.0 or later.","what":"CVE-2022-4524 is a low-severity cross-site scripting vulnerability in Roots soil Plugin, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4524 and fix it if it is affected.\n\nWhat it is: CVE-2022-4524 is a low-severity cross-site scripting vulnerability in Roots soil Plugin, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4524 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- roots/soil (Packagist): affected all versions; fixed in 4.1.0\n- roots/soil (Packagist): affected all versions; fixed in 4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4524/ (Markdown: https://insights.sbomify.com/CVE-2022-4524/index.md)","id":"CVE-2022-4524","markdown":"https://insights.sbomify.com/CVE-2022-4524/index.md","name":"CVE-2022-4524","record":{"aliases":["GHSA-jw6x-4h8h-569x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via the language attribute in the Roots soil plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"soil","vendor":"roots"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Roots soil Plugin CleanUpModule.php language_attributes cross site scripting","id":"CVE-2022-4524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"National Sleep Research Resource sleepdata.org cross site scripting","id":"CVE-2022-4525"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"roots/soil","purl":null,"source":"GHSA-jw6x-4h8h-569x"},{"ecosystem":"Packagist","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"roots/soil","purl":"pkg:composer/roots/soil","source":"GHSA-jw6x-4h8h-569x"}],"prev":{"headline":"vexim2 cross site scripting","id":"CVE-2022-4523"},"products":["soil Plugin"],"published":"2022-12-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Roots"]},"summary":"Attackers can inject malicious scripts via the language attribute in the Roots soil plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2022-4524/"}