# CVE-2022-4524: Roots soil Plugin CleanUpModule.php language_attributes cross site scripting

> Attackers can inject malicious scripts via the language attribute in the Roots soil plugin, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jw6x-4h8h-569x

## What is CVE-2022-4524?

CVE-2022-4524 is a low-severity cross-site scripting vulnerability in Roots soil Plugin, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4524?

2 open source packages ship an affected version, including roots/soil. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roots/soil` | Packagist | All versions | 4.1.0 |
| `roots/soil` | Packagist | All versions | 4.1.0 |

Products: Roots Soil.

## How do I fix CVE-2022-4524?

Upgrade roots/soil to 4.1.0 or later.

## Is CVE-2022-4524 being exploited?

There is no known exploitation of CVE-2022-4524 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4524 and fix it if it is affected.

What it is: CVE-2022-4524 is a low-severity cross-site scripting vulnerability in Roots soil Plugin, published on 15 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4524 in the wild and no public exploit code.

Affected packages and fixed versions:
- roots/soil (Packagist): affected all versions; fixed in 4.1.0
- roots/soil (Packagist): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4524/ (Markdown: https://insights.sbomify.com/CVE-2022-4524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4524
- OSV: https://osv.dev/vulnerability/CVE-2022-4524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4524/
Summaries are generated and may contain mistakes; the official description above is the record.
