# CVE-2022-45382: Cross-site Scripting in Jenkins Naginator Plugin

> Stored XSS in Jenkins Naginator Plugin allows attackers with build name edit rights to execute scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2022
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-h8hf-hxx6-5g6v

## What is CVE-2022-45382?

CVE-2022-45382 is a medium-severity cross-site scripting vulnerability in Jenkins Naginator Plugin, published on 15 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Naginator Plugin 1.18.1 and earlier does not escape display names of source builds in builds that were triggered via Retry action, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to edit build display names.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-45382?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:naginator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:naginator` | Maven | All versions | 1.18.2 |
| `org.jenkins-ci.plugins:naginator` | Maven | All versions | 1.18.2 |

Products: Jenkins Naginator.

## How do I fix CVE-2022-45382?

Upgrade org.jenkins-ci.plugins:naginator to 1.18.2 or later.

## Is CVE-2022-45382 being exploited?

There is no known exploitation of CVE-2022-45382 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45382 and fix it if it is affected.

What it is: CVE-2022-45382 is a medium-severity cross-site scripting vulnerability in Jenkins Naginator Plugin, published on 15 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-45382 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:naginator (Maven): affected all versions; fixed in 1.18.2
- org.jenkins-ci.plugins:naginator (Maven): affected all versions; fixed in 1.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45382/ (Markdown: https://insights.sbomify.com/CVE-2022-45382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45382
- OSV: https://osv.dev/vulnerability/CVE-2022-45382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45382/
Summaries are generated and may contain mistakes; the official description above is the record.
