CVE-2022-45438 Apache Superset: Dashboard metadata information leak

Medium 5.3 Published Updated

Unauthenticated users can access dashboard configuration metadata via REST API when the DASHBOARD_CACHE feature flag is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-45438?

CVE-2022-45438 is a medium-severity vulnerability in Apache Superset, published on 16 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

When explicitly enabling the feature flag DASHBOARD_CACHE (disabled by default), the system allowed for an unauthenticated user to access dashboard configuration metadata using a REST API Get endpoint. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Weakness: CWE-668

Which versions are affected by CVE-2022-45438?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versionsNone
apache-superset PyPIAll versionsNone
apache-superset PyPIAll versions1.5.3, 2.0.1
apache-superset PyPIAll versions to 1.5.2None
apache-superset PyPIAll versions to 1.5.2None
superset BitnamiAll versions1.5.3, 2.0.1

Products include Apache Superset.

How do I fix CVE-2022-45438?

Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.

Is CVE-2022-45438 being exploited?

There is no known exploitation of CVE-2022-45438 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2022-45438, GHSA-8f5j-mgx9-5hm5, PYSEC-2026-778.

Is CVE-2022-45438 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free