# CVE-2022-45438: Apache Superset: Dashboard metadata information leak

> Unauthenticated users can access dashboard configuration metadata via REST API when the DASHBOARD_CACHE feature flag is enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** BIT-superset-2022-45438, GHSA-8f5j-mgx9-5hm5, PYSEC-2026-778

## What is CVE-2022-45438?

CVE-2022-45438 is a medium-severity vulnerability in Apache Superset, published on 16 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When explicitly enabling the feature flag DASHBOARD_CACHE (disabled by default), the system allowed for an unauthenticated user to access dashboard configuration metadata using a REST API Get endpoint. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2022-45438?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | None |
| `apache-superset` | PyPI | All versions | None |
| `apache-superset` | PyPI | All versions | 1.5.3, 2.0.1 |
| `apache-superset` | PyPI | All versions to 1.5.2 | None |
| `apache-superset` | PyPI | All versions to 1.5.2 | None |
| `superset` | Bitnami | All versions | 1.5.3, 2.0.1 |

Products: Apache Superset.

## How do I fix CVE-2022-45438?

Upgrade apache-superset to a fixed version for your release line: 1.5.3 or 2.0.1.

## Is CVE-2022-45438 being exploited?

There is no known exploitation of CVE-2022-45438 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45438 and fix it if it is affected.

What it is: CVE-2022-45438 is a medium-severity vulnerability in Apache Superset, published on 16 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-45438 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; no fix listed
- apache-superset (PyPI): affected all versions; no fix listed
- apache-superset (PyPI): affected all versions; fixed in 1.5.3, 2.0.1
- apache-superset (PyPI): affected all versions up to 1.5.2; no fix listed
- apache-superset (PyPI): affected all versions up to 1.5.2; no fix listed
- superset (Bitnami): affected all versions; fixed in 1.5.3, 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45438/ (Markdown: https://insights.sbomify.com/CVE-2022-45438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45438
- OSV: https://osv.dev/vulnerability/CVE-2022-45438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45438/
Summaries are generated and may contain mistakes; the official description above is the record.
