# CVE-2022-45442: Sinatra vulnerable to Reflected File Download attack

> Attackers can exploit reflected file download vulnerabilities in Sinatra to execute malicious code or bypass security controls via crafted filenames.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Nov 2022
- **Updated:** 4 Nov 2025
- **Also known as:** ALSA-2023:0855, ALSA-2023:0974, DEBIAN-CVE-2022-45442, DLA-3264-1, GHSA-2x8x-jmrp-phxw, MGASA-2023-0029, OESA-2024-2474, OESA-2024-2475, OESA-2024-2476, OESA-2024-2477, OESA-2024-2490, RHSA-2023:0393, RHSA-2023:0427, RHSA-2023:0506, RHSA-2023:0527, RHSA-2023:0855, RHSA-2023:0857, RHSA-2023:0974, RLSA-2023:0855, UBUNTU-CVE-2022-45442

## What is CVE-2022-45442?

CVE-2022-45442 is a high-severity vulnerability in Debian Debian Linux, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Sinatra is a domain-specific language for creating web applications in Ruby. An issue was discovered in Sinatra 2.0 before 2.2.3 and 3.0 before 3.0.4. An application is vulnerable to a reflected file download (RFD) attack that sets the Content-Disposition header of a response when the filename is derived from user-supplied input. Version 2.2.3 and 3.0.4 contain patches for this issue.

Weakness: CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2022-45442?

4 open source packages ship an affected version, including sinatra. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sinatra` | RubyGems | From 2.0.0 | 2.2.3 |
| `sinatra` | RubyGems | From 2.0.0 | 2.2.3 |
| `sinatra` | RubyGems | From 3.0 | 3.0.4 |
| `sinatra` | RubyGems | From 3.0 | 3.0.4 |
| `pcs` | AlmaLinux:8 | All versions | 0.10.14-5.el8_7.2.alma |
| `pcs-snmp` | AlmaLinux:8 | All versions | 0.10.14-5.el8_7.2.alma |
| `pcs` | AlmaLinux:9 | All versions | 0.11.3-4.el9_1.2 |
| `pcs-snmp` | AlmaLinux:9 | All versions | 0.11.3-4.el9_1.2 |
| `pcs` | Red Hat:enterprise_linux:8::highavailability | All versions | 0:0.10.14-5.el8_7.2 |
| `pcs-snmp` | Red Hat:enterprise_linux:8::highavailability | All versions | 0:0.10.14-5.el8_7.2 |
| `pcs` | Red Hat:enterprise_linux:8::resilientstorage | All versions | 0:0.10.14-5.el8_7.2 |
| `pcs-snmp` | Red Hat:enterprise_linux:8::resilientstorage | All versions | 0:0.10.14-5.el8_7.2 |
| `pcs` | Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.3-4.el9_1.2 |
| `pcs-snmp` | Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.3-4.el9_1.2 |
| `pcs` | Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.3-4.el9_1.2 |
| `pcs-snmp` | Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.3-4.el9_1.2 |
| `pcs` | Red Hat:rhel_e4s:8.1::highavailability | All versions | 0:0.10.2-4.el8_1.3 |
| `pcs-snmp` | Red Hat:rhel_e4s:8.1::highavailability | All versions | 0:0.10.2-4.el8_1.3 |
| `pcs` | Red Hat:rhel_e4s:8.2::highavailability | All versions | 0:0.10.4-6.el8_2.4 |
| `pcs-snmp` | Red Hat:rhel_e4s:8.2::highavailability | All versions | 0:0.10.4-6.el8_2.4 |
| `pcs` | Red Hat:rhel_eus:8.4::highavailability | All versions | 0:0.10.8-1.el8_4.3 |
| `pcs-snmp` | Red Hat:rhel_eus:8.4::highavailability | All versions | 0:0.10.8-1.el8_4.3 |
| `pcs` | Red Hat:rhel_eus:8.4::resilientstorage | All versions | 0:0.10.8-1.el8_4.3 |
| `pcs-snmp` | Red Hat:rhel_eus:8.4::resilientstorage | All versions | 0:0.10.8-1.el8_4.3 |
| `pcs` | Red Hat:rhel_eus:8.6::highavailability | All versions | 0:0.10.12-6.el8_6.3 |
| `pcs-snmp` | Red Hat:rhel_eus:8.6::highavailability | All versions | 0:0.10.12-6.el8_6.3 |
| `pcs` | Red Hat:rhel_eus:8.6::resilientstorage | All versions | 0:0.10.12-6.el8_6.3 |
| `pcs-snmp` | Red Hat:rhel_eus:8.6::resilientstorage | All versions | 0:0.10.12-6.el8_6.3 |
| `pcs` | Red Hat:rhel_eus:9.0::highavailability | All versions | 0:0.11.1-10.el9_0.3 |
| `pcs-snmp` | Red Hat:rhel_eus:9.0::highavailability | All versions | 0:0.11.1-10.el9_0.3 |
| `pcs` | Red Hat:rhel_eus:9.0::resilientstorage | All versions | 0:0.11.1-10.el9_0.3 |
| `pcs-snmp` | Red Hat:rhel_eus:9.0::resilientstorage | All versions | 0:0.11.1-10.el9_0.3 |
| `pcs` | Red Hat:rhel_tus:8.2::highavailability | All versions | 0:0.10.4-6.el8_2.4 |
| `pcs-snmp` | Red Hat:rhel_tus:8.2::highavailability | All versions | 0:0.10.4-6.el8_2.4 |
| `pcs` | Rocky Linux:8 | All versions | 0:0.10.14-5.el8_7.2 |

Products: Debian Debian Linux, Sinatrarb Sinatra.

## How do I fix CVE-2022-45442?

Upgrade sinatra to a fixed version for your release line: 2.2.3 or 3.0.4.

## Is CVE-2022-45442 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45442 exists.

Public exploit code:

- Private fork of refile/refile (pinned at c4ac577c) with sinatra ceiling raised to < 4.0 for CVE-2022-45442. See sc-47428. (github_poc): https://github.com/boost-legal/refile

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45442 and fix it if it is affected.

What it is: CVE-2022-45442 is a high-severity vulnerability in Debian Debian Linux, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45442 exists.

Affected packages and fixed versions:
- sinatra (RubyGems): affected from 2.0.0; fixed in 2.2.3
- sinatra (RubyGems): affected from 2.0.0; fixed in 2.2.3
- sinatra (RubyGems): affected from 3.0; fixed in 3.0.4
- sinatra (RubyGems): affected from 3.0; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45442/ (Markdown: https://insights.sbomify.com/CVE-2022-45442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45442
- OSV: https://osv.dev/vulnerability/CVE-2022-45442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45442/
Summaries are generated and may contain mistakes; the official description above is the record.
