CVE-2022-45462 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability

Critical 9.8 Published Updated

Authenticated attackers can execute arbitrary commands via alarm instance management if specific commands are configured.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-45462?

CVE-2022-45462 is a critical command injection vulnerability in Apache DolphinScheduler, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher

Weakness: CWE-77

Which versions are affected by CVE-2022-45462?

2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler-alert-plugins. It affects 1 product.

PackageAffectedFixed in
org.apache.dolphinscheduler:dolphinscheduler-alert-plugins MavenAll versions2.0.6
org.apache.dolphinscheduler:dolphinscheduler-alert-plugins MavenAll versions2.0.6

Products include Apache Dolphinscheduler.

How do I fix CVE-2022-45462?

Upgrade org.apache.dolphinscheduler:dolphinscheduler-alert-plugins to 2.0.6 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2022-45462 being exploited?

There is no known exploitation of CVE-2022-45462 in the wild and no public exploit code.

Sources

Also known as GHSA-wqg7-mx6p-2rw3.

Is CVE-2022-45462 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free