CVE-2022-45589 SQL injection in n/a

High 7.2 Published Updated

Attackers can perform SQL injection attacks against the Talend ESB Runtime provisioning service, potentially accessing or modifying data.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-45589?

CVE-2022-45589 is a high-severity SQL injection vulnerability in n/a, published on 6 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

All versions before 8.0.1-R2022-10-RT and 7.3.1-R2022-09-RT of the Talend ESB Runtime are potentially vulnerable to SQL Injection attacks in the provisioning service only. Users of the provisioning service should upgrade to either 8.0.1-R2022-10-RT or 7.3.1-R2022-09-RT or a later release and use it in place of the previous version.

Weakness: CWE-89

Which versions are affected by CVE-2022-45589?

It affects 1 product.

Products include Talend Esb Runtime.

How do I fix CVE-2022-45589?

No fix has been published for CVE-2022-45589 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2022-45589 being exploited?

There is no known exploitation of CVE-2022-45589 in the wild and no public exploit code.

Sources

Also known as GHSA-qffj-xvw3-9g6g.

Is CVE-2022-45589 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free