# CVE-2022-45589: SQL injection in n/a

> Attackers can perform SQL injection attacks against the Talend ESB Runtime provisioning service, potentially accessing or modifying data.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Feb 2023
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-qffj-xvw3-9g6g

## What is CVE-2022-45589?

CVE-2022-45589 is a high-severity SQL injection vulnerability in n/a, published on 6 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

All versions before 8.0.1-R2022-10-RT and 7.3.1-R2022-09-RT of the Talend ESB Runtime are potentially vulnerable to SQL Injection attacks in the provisioning service only. Users of the provisioning service should upgrade to either 8.0.1-R2022-10-RT or 7.3.1-R2022-09-RT or a later release and use it in place of the previous version.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-45589?

It affects 1 product.


Products: Talend Esb Runtime.

## How do I fix CVE-2022-45589?

No fix has been published for CVE-2022-45589 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-45589 being exploited?

There is no known exploitation of CVE-2022-45589 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-40684](https://insights.sbomify.com/CVE-2021-40684/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45589 and fix it if it is affected.

What it is: CVE-2022-45589 is a high-severity SQL injection vulnerability in n/a, published on 6 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-45589 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45589/ (Markdown: https://insights.sbomify.com/CVE-2022-45589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45589
- OSV: https://osv.dev/vulnerability/CVE-2022-45589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45589/
Summaries are generated and may contain mistakes; the official description above is the record.
