# CVE-2022-4565: Dromara HuTool cn.hutool.core.util.ZipUtil.java resource consumption

> Remote attackers can cause resource consumption in Dromara HuTool via ZipUtil, leading to denial of service.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-47vx-fqr5-j2gw

## What is CVE-2022-4565?

CVE-2022-4565 is a medium-severity denial of service vulnerability in Dromara HuTool, published on 16 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in Dromara HuTool up to 5.8.10. This vulnerability affects unknown code of the file cn.hutool.core.util.ZipUtil.java. The manipulation leads to resource consumption. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 5.8.11 is able to address this issue. It is recommended to upgrade the affected component. VDB-215974 is the identifier assigned to this vulnerability.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2022-4565?

2 open source packages ship an affected version, including cn.hutool:hutool-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cn.hutool:hutool-core` | Maven | All versions | 5.8.11 |
| `cn.hutool:hutool-core` | Maven | All versions | 5.8.11 |

Products: Hutool Hutool.

## How do I fix CVE-2022-4565?

Upgrade cn.hutool:hutool-core to 5.8.11 or later.

## Is CVE-2022-4565 being exploited?

There is no known exploitation of CVE-2022-4565 in the wild and no public exploit code.

## Other vulnerabilities in Dromara HuTool

- [CVE-2023-42276](https://insights.sbomify.com/CVE-2023-42276/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-42277](https://insights.sbomify.com/CVE-2023-42277/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-24162](https://insights.sbomify.com/CVE-2023-24162/): Dromara Hutool Deserialization of Untrusted Data vulnerability (critical 9.8)
- [CVE-2023-24163](https://insights.sbomify.com/CVE-2023-24163/): Dromara hutool vulnerable to SQL Injection (critical 9.8)
- [CVE-2022-22885](https://insights.sbomify.com/CVE-2022-22885/): Improper Certificate Validation in Hutool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4565 and fix it if it is affected.

What it is: CVE-2022-4565 is a medium-severity denial of service vulnerability in Dromara HuTool, published on 16 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4565 in the wild and no public exploit code.

Affected packages and fixed versions:
- cn.hutool:hutool-core (Maven): affected all versions; fixed in 5.8.11
- cn.hutool:hutool-core (Maven): affected all versions; fixed in 5.8.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4565/ (Markdown: https://insights.sbomify.com/CVE-2022-4565/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4565
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4565
- OSV: https://osv.dev/vulnerability/CVE-2022-4565

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4565/
Summaries are generated and may contain mistakes; the official description above is the record.
