# CVE-2022-45693: Jettison Out-of-bounds Write vulnerability

> Attackers can cause a Denial of Service in Jettison library via crafted input triggering stack overflow.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2022
- **Updated:** 22 Apr 2025
- **Also known as:** CLEANSTART-2026-NZ47106, DEBIAN-CVE-2022-45693, ECHO-fd53-374a-d3fa, GHSA-grr4-wv38-f68w, UBUNTU-CVE-2022-45693

## What is CVE-2022-45693?

CVE-2022-45693 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jettison before v1.5.2 was discovered to contain a stack overflow via the map parameter. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted string.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-45693?

2 open source packages ship an affected version, including org.codehaus.jettison:jettison. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.codehaus.jettison:jettison` | Maven | All versions | 1.5.2 |
| `org.codehaus.jettison:jettison` | Maven | All versions | 1.5.2 |

Products: Debian Debian Linux, Jettison Project Jettison.

## How do I fix CVE-2022-45693?

Upgrade org.codehaus.jettison:jettison to 1.5.2 or later.

## Is CVE-2022-45693 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45693 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45693 and fix it if it is affected.

What it is: CVE-2022-45693 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45693 exists.

Affected packages and fixed versions:
- org.codehaus.jettison:jettison (Maven): affected all versions; fixed in 1.5.2
- org.codehaus.jettison:jettison (Maven): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45693/ (Markdown: https://insights.sbomify.com/CVE-2022-45693/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45693
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45693
- OSV: https://osv.dev/vulnerability/CVE-2022-45693

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45693/
Summaries are generated and may contain mistakes; the official description above is the record.
