# CVE-2022-45801: Apache StreamPark (incubating): LDAP Injection Vulnerability

> Attackers can perform LDAP injection to gain unauthorized permissions or modify LDAP data when LDAP login is enabled.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2023
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-pjfj-qvqw-3f6v

## What is CVE-2022-45801?

CVE-2022-45801 is a medium-severity vulnerability in Apache StreamPark (incubating), published on 1 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache StreamPark 1.0.0 to 2.0.0 have a LDAP injection vulnerability.
LDAP Injection is an attack used to exploit web based applications
that construct LDAP statements based on user input. When an
application fails to properly sanitize user input, it's possible to
modify LDAP statements through techniques similar to SQL Injection.
LDAP injection attacks could result in the granting of permissions to
unauthorized queries, and content modification inside the LDAP tree.
This risk may only occur when the user logs in with ldap, and the user
name and password login will not be affected, Users of the affected
versions should upgrade to Apache StreamPark 2.0.0 or later.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-45801?

2 open source packages ship an affected version, including org.apache.streampark:streampark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampark:streampark` | Maven | From 1.0.0 | 2.0.0 |
| `org.apache.streampark:streampark` | Maven | From 1.0.0 | 2.0.0 |

Products: Apache Streampark.

## How do I fix CVE-2022-45801?

Upgrade org.apache.streampark:streampark to 2.0.0 or later.

## Is CVE-2022-45801 being exploited?

There is no known exploitation of CVE-2022-45801 in the wild and no public exploit code.

## Other vulnerabilities in Apache StreamPark (incubating)

- [CVE-2022-45802](https://insights.sbomify.com/CVE-2022-45802/): Apache StreamPark (incubating): Upload any file to any directory (critical 9.8)
- [CVE-2024-29070](https://insights.sbomify.com/CVE-2024-29070/): Apache StreamPark: session not invalidated after logout (critical 9.1)
- [CVE-2022-46365](https://insights.sbomify.com/CVE-2022-46365/): Apache StreamPark (incubating): Logic error causing any account reset (critical 9.1)
- [CVE-2024-29178](https://insights.sbomify.com/CVE-2024-29178/): Apache StreamPark: FreeMarker SSTI RCE Vulnerability (high 8.8)
- [CVE-2023-52291](https://insights.sbomify.com/CVE-2023-52291/): Apache StreamPark (incubating): Unchecked maven build params could trigger remote command execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45801 and fix it if it is affected.

What it is: CVE-2022-45801 is a medium-severity vulnerability in Apache StreamPark (incubating), published on 1 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-45801 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.streampark:streampark (Maven): affected from 1.0.0; fixed in 2.0.0
- org.apache.streampark:streampark (Maven): affected from 1.0.0; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45801/ (Markdown: https://insights.sbomify.com/CVE-2022-45801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45801
- OSV: https://osv.dev/vulnerability/CVE-2022-45801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45801/
Summaries are generated and may contain mistakes; the official description above is the record.
