CVE-2022-4582 starter-public-edition-4 cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts in the context of other users via a cross-site scripting vulnerability in starter-public-edition-4.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-4582?

CVE-2022-4582 is a low-severity cross-site scripting vulnerability in unspecified starter-public-edition-4, published on 17 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in starter-public-edition-4 up to 4.6.10. It has been classified as problematic. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.6.11 is able to address this issue. The name of the patch is 2606983c20f6ea3430ac4b36b3d2e88aafef45da. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216168.

Weakness: CWE-707

Which versions are affected by CVE-2022-4582?

It affects 1 product.

Products include Starter-Public-Edition-4 Project Starter-Public-Edition-4.

How do I fix CVE-2022-4582?

No fix has been published for CVE-2022-4582 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-4582 being exploited?

There is no known exploitation of CVE-2022-4582 in the wild and no public exploit code.

Sources

Also known as GHSA-xxg6-wvf8-73xv.

Is CVE-2022-4582 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free