{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4582 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4582 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4582 is a low-severity cross-site scripting vulnerability in unspecified starter-public-edition-4, published on 17 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4582 and fix it if it is affected.\n\nWhat it is: CVE-2022-4582 is a low-severity cross-site scripting vulnerability in unspecified starter-public-edition-4, published on 17 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4582 in the wild and no public exploit code.\n\nAffected product: unspecified starter-public-edition-4. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4582/ (Markdown: https://insights.sbomify.com/CVE-2022-4582/index.md)","id":"CVE-2022-4582","markdown":"https://insights.sbomify.com/CVE-2022-4582/index.md","name":"CVE-2022-4582","record":{"aliases":["GHSA-xxg6-wvf8-73xv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"starter-public-edition-4","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts in the context of other users via a cross-site scripting vulnerability in starter-public-edition-4.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"starter-public-edition-4","vendor":"starter-public-edition-4_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability was found in starter-public-edition-4 up to 4.6.10. It has been classified as problematic. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.6.11 is able to address this issue. The name of the patch is 2606983c20f6ea3430ac4b36b3d2e88aafef45da. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216168.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"starter-public-edition-4 cross site scripting","id":"CVE-2022-4582","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"jLEMS JUtil.java unpackJar path traversal","id":"CVE-2022-4583"},"packages":[],"prev":{"headline":"1j01 mind-map app.coffee cross site scripting","id":"CVE-2022-4581"},"products":["starter-public-edition-4"],"published":"2022-12-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Remote attackers can execute arbitrary scripts in the context of other users via a cross-site scripting vulnerability in starter-public-edition-4.","url":"https://insights.sbomify.com/CVE-2022-4582/"}