# CVE-2022-4582: starter-public-edition-4 cross site scripting

> Remote attackers can execute arbitrary scripts in the context of other users via a cross-site scripting vulnerability in starter-public-edition-4.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-xxg6-wvf8-73xv

## What is CVE-2022-4582?

CVE-2022-4582 is a low-severity cross-site scripting vulnerability in unspecified starter-public-edition-4, published on 17 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in starter-public-edition-4 up to 4.6.10. It has been classified as problematic. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.6.11 is able to address this issue. The name of the patch is 2606983c20f6ea3430ac4b36b3d2e88aafef45da. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216168.

Weakness: CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-4582?

It affects 1 product.


Products: Starter-Public-Edition-4 Project Starter-Public-Edition-4.

## How do I fix CVE-2022-4582?

No fix has been published for CVE-2022-4582 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4582 being exploited?

There is no known exploitation of CVE-2022-4582 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4582 and fix it if it is affected.

What it is: CVE-2022-4582 is a low-severity cross-site scripting vulnerability in unspecified starter-public-edition-4, published on 17 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4582 in the wild and no public exploit code.

Affected product: unspecified starter-public-edition-4. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4582/ (Markdown: https://insights.sbomify.com/CVE-2022-4582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4582
- OSV: https://osv.dev/vulnerability/CVE-2022-4582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4582/
Summaries are generated and may contain mistakes; the official description above is the record.
