# CVE-2022-45855: Apache Ambari: Allows authenticated metrics consumers to perform RCE

> Authenticated users can execute arbitrary code via SpringEL injection in Apache Ambari metrics source.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2023
- **Updated:** 4 Oct 2024
- **Also known as:** GHSA-p7w2-784m-qpq9

## What is CVE-2022-45855?

CVE-2022-45855 is a high-severity code injection vulnerability in Apache Ambari, published on 12 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2022-45855?

2 open source packages ship an affected version, including org.apache.ambari:ambari. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ambari:ambari` | Maven | From 2.7.0 | 2.7.7 |
| `org.apache.ambari:ambari` | Maven | From 2.7.0 | 2.7.7 |

Products: Apache Ambari.

## How do I fix CVE-2022-45855?

Upgrade org.apache.ambari:ambari to 2.7.7 or later.

## Is CVE-2022-45855 being exploited?

There is no known exploitation of CVE-2022-45855 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ambari

- [CVE-2017-5642](https://insights.sbomify.com/CVE-2017-5642/): Misconfiguration in Apache Ambari (critical 9.8)
- [CVE-2014-3582](https://insights.sbomify.com/CVE-2014-3582/): Command injection in n/a (critical 9.8)
- [CVE-2016-6807](https://insights.sbomify.com/CVE-2016-6807/): Apache Ambari Improper Access Control (critical 9.8)
- [CVE-2024-51941](https://insights.sbomify.com/CVE-2024-51941/): Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts (high 8.8)
- [CVE-2025-23196](https://insights.sbomify.com/CVE-2025-23196/): Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45855 and fix it if it is affected.

What it is: CVE-2022-45855 is a high-severity code injection vulnerability in Apache Ambari, published on 12 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-45855 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ambari:ambari (Maven): affected from 2.7.0; fixed in 2.7.7
- org.apache.ambari:ambari (Maven): affected from 2.7.0; fixed in 2.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45855/ (Markdown: https://insights.sbomify.com/CVE-2022-45855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45855
- OSV: https://osv.dev/vulnerability/CVE-2022-45855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45855/
Summaries are generated and may contain mistakes; the official description above is the record.
