CVE-2022-45875 Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
Authenticated users can execute arbitrary commands via improper validation in the script alert plugin of Apache DolphinScheduler.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-45875?
CVE-2022-45875 is a critical command injection vulnerability in Apache DolphinScheduler, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. This attack can be performed only by authenticated users which can login to DS.
Weakness: CWE-20
Which versions are affected by CVE-2022-45875?
5 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler and apache-dolphinscheduler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.dolphinscheduler:dolphinscheduler Maven | All versions | 3.0.2 |
org.apache.dolphinscheduler:dolphinscheduler Maven | All versions | 3.0.2 |
org.apache.dolphinscheduler:dolphinscheduler Maven | From 3.1.0 | 3.1.1 |
org.apache.dolphinscheduler:dolphinscheduler Maven | From 3.1.0 | 3.1.1 |
apache-dolphinscheduler PyPI | All versions | 3.0.2 |
Products include Apache Dolphinscheduler.
How do I fix CVE-2022-45875?
Upgrade org.apache.dolphinscheduler:dolphinscheduler to a fixed version for your release line: 3.0.2 or 3.1.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-45875 being exploited?
There is no known exploitation of CVE-2022-45875 in the wild and no public exploit code.
Other vulnerabilities in Apache DolphinScheduler
- CVE-2024-43166 Apache DolphinScheduler Incorrect Default Permissions Vulnerability
- CVE-2024-43202 Apache DolphinScheduler: Remote Code Execution Vulnerability
- CVE-2023-49109 Remote Code Execution in Apache Dolphinscheduler
- CVE-2022-45462 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
- CVE-2020-11974 Remote code execution in DolphinScheduler
Sources
Also known as GHSA-3xh5-8hvq-rc8x, PYSEC-2023-4.