# CVE-2022-45875: Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin

> Authenticated users can execute arbitrary commands via improper validation in the script alert plugin of Apache DolphinScheduler.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-3xh5-8hvq-rc8x, PYSEC-2023-4

## What is CVE-2022-45875?

CVE-2022-45875 is a critical command injection vulnerability in Apache DolphinScheduler, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability.  This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions.
This attack can be performed only by authenticated users which can login to DS.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-45875?

5 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler and apache-dolphinscheduler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 3.0.2 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 3.0.2 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 3.1.0 | 3.1.1 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 3.1.0 | 3.1.1 |
| `apache-dolphinscheduler` | PyPI | All versions | 3.0.2 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2022-45875?

Upgrade org.apache.dolphinscheduler:dolphinscheduler to a fixed version for your release line: 3.0.2 or 3.1.1.

## Is CVE-2022-45875 being exploited?

There is no known exploitation of CVE-2022-45875 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)
- [CVE-2020-11974](https://insights.sbomify.com/CVE-2020-11974/): Remote code execution in DolphinScheduler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45875 and fix it if it is affected.

What it is: CVE-2022-45875 is a critical command injection vulnerability in Apache DolphinScheduler, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-45875 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 3.0.2
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 3.0.2
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 3.1.0; fixed in 3.1.1
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 3.1.0; fixed in 3.1.1
- apache-dolphinscheduler (PyPI): affected all versions; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45875/ (Markdown: https://insights.sbomify.com/CVE-2022-45875/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45875
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45875
- OSV: https://osv.dev/vulnerability/CVE-2022-45875

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45875/
Summaries are generated and may contain mistakes; the official description above is the record.
