{"answers":{"affected":"3 open source packages ship an affected version, including paddlepaddle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-45908 in the wild and no public exploit code.","fix":"Upgrade paddlepaddle to 2.4 or later.","what":"CVE-2022-45908 is a critical code injection vulnerability in n/a, published on 26 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-45908 and fix it if it is affected.\n\nWhat it is: CVE-2022-45908 is a critical code injection vulnerability in n/a, published on 26 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-45908 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paddlepaddle (PyPI): affected all versions; fixed in 2.4\n- paddlepaddle (PyPI): affected all versions; fixed in 2.4\n- paddlepaddle (PyPI): affected all versions; fixed in 2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-45908/ (Markdown: https://insights.sbomify.com/CVE-2022-45908/index.md)","id":"CVE-2022-45908","markdown":"https://insights.sbomify.com/CVE-2022-45908/index.md","name":"CVE-2022-45908","record":{"aliases":["GHSA-83g7-8fch-p37m","PYSEC-2026-443"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PaddlePaddle audio library","requires_auth":"none","summary":"Attackers can execute arbitrary code via the get_window function in PaddlePaddle's audio module due to unsafe eval usage.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"paddlepaddle","vendor":"paddlepaddle"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"In PaddlePaddle before 2.4, paddle.audio.functional.get_window is vulnerable to code injection because it calls eval on a user-supplied winstr. This may lead to arbitrary code execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PaddlePaddle vulnerable to code injection via winstr","id":"CVE-2022-45908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2022-45909"},"packages":[{"ecosystem":"PyPI","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":null,"source":"GHSA-83g7-8fch-p37m"},{"ecosystem":"PyPI","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"GHSA-83g7-8fch-p37m"},{"ecosystem":"PyPI","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"PYSEC-2026-443"}],"prev":{"headline":"PyTorch vulnerable to arbitrary code execution","id":"CVE-2022-45907"},"products":["n/a"],"published":"2022-11-26","related":[{"cvss_score":10,"headline":"PaddlePaddle vulnerable to Code Injection","id":"CVE-2022-46742","kev_date_added":null,"published":"2022-12-07"},{"cvss_score":9.6,"headline":"Command injection in get_online_pass_interval","id":"CVE-2023-52310","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in _wget_download","id":"CVE-2023-52311","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in convert_shape_compare","id":"CVE-2023-52314","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in fs.py","id":"CVE-2023-38673","kev_date_added":null,"published":"2023-07-26"},{"cvss_score":9.4,"headline":"PaddlePaddle vulnerable to remote code execution","id":"CVE-2024-0917","kev_date_added":null,"published":"2024-03-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-25","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via the get_window function in PaddlePaddle's audio module due to unsafe eval usage.","url":"https://insights.sbomify.com/CVE-2022-45908/"}