# CVE-2022-45968: AList vulnerable to Improper Preservation of Permissions

> An attacker with file upload permissions can upload arbitrary files to any folder, potentially leading to code execution or data modification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-4gjr-vgfx-9qvw, GO-2022-1161

## What is CVE-2022-45968?

CVE-2022-45968 is a high-severity vulnerability in n/a, published on 12 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Alist v3.4.0 is vulnerable to File Upload. A user with only file upload permission can upload any file to any folder (even a password protected one).

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-45968?

4 open source packages ship an affected version, including github.com/alist-org/alist/v3 and github.com/alist-org/alist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/alist-org/alist/v3` | Go | All versions | 3.5.1 |
| `github.com/alist-org/alist/v3` | Go | All versions | 3.5.1 |
| `github.com/alist-org/alist/v3` | Go | All versions | 3.5.1 |
| `github.com/alist-org/alist` | Go | All versions | None |

Products: Alistgo Alist.

## How do I fix CVE-2022-45968?

Upgrade github.com/alist-org/alist/v3 to 3.5.1 or later.

## Is CVE-2022-45968 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45968 exists.

## Other vulnerabilities in n/a

- [CVE-2022-45969](https://insights.sbomify.com/CVE-2022-45969/): Alist vulnerable to Path Traversal (critical 9.8)
- [CVE-2026-25160](https://insights.sbomify.com/CVE-2026-25160/): Alist has Insecure TLS Config (critical 9.1)
- [CVE-2026-25161](https://insights.sbomify.com/CVE-2026-25161/): Alist vulnerable to Path Traversal in multiple file operation handlers (high 8.8)
- [CVE-2023-33498](https://insights.sbomify.com/CVE-2023-33498/): alist Incorrect Access Control vulnerability (high 8.8)
- [CVE-2023-31726](https://insights.sbomify.com/CVE-2023-31726/): Missing authorization in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-45968 and fix it if it is affected.

What it is: CVE-2022-45968 is a high-severity vulnerability in n/a, published on 12 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45968 exists.

Affected packages and fixed versions:
- github.com/alist-org/alist/v3 (Go): affected all versions; fixed in 3.5.1
- github.com/alist-org/alist/v3 (Go): affected all versions; fixed in 3.5.1
- github.com/alist-org/alist/v3 (Go): affected all versions; fixed in 3.5.1
- github.com/alist-org/alist (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-45968/ (Markdown: https://insights.sbomify.com/CVE-2022-45968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-45968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-45968
- OSV: https://osv.dev/vulnerability/CVE-2022-45968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-45968/
Summaries are generated and may contain mistakes; the official description above is the record.
