CVE-2022-45969 Alist vulnerable to Path Traversal

Critical 9.8 Published Updated

Attackers can exploit a directory traversal flaw in Alist to read arbitrary files from the server filesystem.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-45969?

CVE-2022-45969 is a critical path traversal vulnerability in n/a, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Alist v3.4.0 is vulnerable to Directory Traversal,

Weakness: CWE-22

Which versions are affected by CVE-2022-45969?

4 open source packages ship an affected version, including github.com/alist-org/alist/v3 and github.com/alist-org/alist. It affects 1 product.

PackageAffectedFixed in
github.com/alist-org/alist/v3 GoAll versions3.6.0
github.com/alist-org/alist/v3 GoAll versions3.6.0
github.com/alist-org/alist/v3 GoAll versions3.6.0
github.com/alist-org/alist GoAll versionsNone

Products include Alistgo Alist.

How do I fix CVE-2022-45969?

Upgrade github.com/alist-org/alist/v3 to 3.6.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2022-45969 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-45969 exists.

Sources

Also known as GHSA-pmg2-rph8-p8r6, GO-2022-1171.

Is CVE-2022-45969 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free