CVE-2022-4604 wp-english-wp-admin Plugin english-wp-admin.php register_endpoints cross-site request forgery

Medium 4.3 Published Updated

A cross-site request forgery vulnerability in the wp-english-wp-admin plugin allows attackers to perform unauthorized actions on behalf of authenticated users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-4604?

CVE-2022-4604 is a medium-severity vulnerability in wp-english-wp-admin Plugin, published on 18 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic was found in wp-english-wp-admin Plugin up to 1.5.1. Affected by this vulnerability is the function register_endpoints of the file english-wp-admin.php. The manipulation leads to cross-site request forgery. The attack can be launched remotely. Upgrading to version 1.5.2 is able to address this issue. The name of the patch is ad4ba171c974c65c3456e7c6228f59f40783b33d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216199.

Weakness: CWE-352

Which versions are affected by CVE-2022-4604?

It affects 1 product.

Products include Wp-English-Wp-Admin Project Wp-English-Wp-Admin.

How do I fix CVE-2022-4604?

No fix has been published for CVE-2022-4604 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-4604 being exploited?

There is no known exploitation of CVE-2022-4604 in the wild and no public exploit code.

Sources

Also known as GHSA-6m5v-7hpg-vqfv.

Is CVE-2022-4604 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free