# CVE-2022-46147: Drag and Drop XBlock v2 has XSS Issues in Xblock Input Fields

> Attackers can inject malicious scripts into drag-and-drop XBlock fields, potentially compromising user sessions on Open edX platforms.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-qv6c-367r-3w6q, PYSEC-2022-43175

## What is CVE-2022-46147?

CVE-2022-46147 is a high-severity cross-site scripting vulnerability in openedx xblock-drag-and-drop-v2, published on 28 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Drag and Drop XBlock v2 implements a drag-and-drop style problem, where a learner has to drag items to zones on a target image. Versions prior to 3.0.0 are vulnerable to cross-site scripting in multiple XBlock Fields. Any platform that has deployed the XBlock may be impacted. Version 3.0.0 contains a patch for this issue. There are no known workarounds.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-46147?

3 open source packages ship an affected version, including xblock-drag-and-drop-v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xblock-drag-and-drop-v2` | PyPI | All versions | 3.0.0 |
| `xblock-drag-and-drop-v2` | PyPI | All versions | 3.0.0 |
| `xblock-drag-and-drop-v2` | PyPI | All versions | 3.0.0 |

Products: Openedx Xblock-Drag-and-Drop-V2.

## How do I fix CVE-2022-46147?

Upgrade xblock-drag-and-drop-v2 to 3.0.0 or later.

## Is CVE-2022-46147 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46147 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46147 and fix it if it is affected.

What it is: CVE-2022-46147 is a high-severity cross-site scripting vulnerability in openedx xblock-drag-and-drop-v2, published on 28 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46147 exists.

Affected packages and fixed versions:
- xblock-drag-and-drop-v2 (PyPI): affected all versions; fixed in 3.0.0
- xblock-drag-and-drop-v2 (PyPI): affected all versions; fixed in 3.0.0
- xblock-drag-and-drop-v2 (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46147/ (Markdown: https://insights.sbomify.com/CVE-2022-46147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46147
- OSV: https://osv.dev/vulnerability/CVE-2022-46147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46147/
Summaries are generated and may contain mistakes; the official description above is the record.
